How to fix: Paint.NET "breaks" with Vista SP2 Beta

I’ve had some reports that installing the Windows Vista SP2 beta (or “CPP”) breaks Paint.NET v3.36.

You’ll get an error message like so:

Contrary to the error, Paint.NET v3.36 does not require .NET Framework 3.5 SP1.

There are two ways to fix this:

1. Install .NET Framework 3.5 SP1. I recommend doing this anyway, because it has numerous fixes and performance improvements that make Paint.NET happy.

2. Go to the directory you installed Paint.NET, and remove all the files with the “.exe.config” extension. This will un-confuse the .NET loader stuff.

This seems to be something related to the .NET Client Profile, although I’m not sure what the root cause is. I’ll be reporting this bug to the right people, so that it can be fixed.

Advertisements

6 thoughts on “How to fix: Paint.NET "breaks" with Vista SP2 Beta

  1. Lucas says:

    The config file does specify the client profile sku, which I think requires 3.5 SP1.

  2. ShK_828 says:

    wow SP2 vista, i dont think that would even be worth downloading.but i guess everyones going to eventually end up downloading .net 3.5 sp1, as it will be for paint.net 4.0?

  3. mf3imp says:

    Hi Rick, strangely I’ve the same error message (in italian) using XP and a silent installer of .NET Framework 2.0 SP2 in an unattended installation. Using the silent installer of Roguespears (which I think is a reference for its work) also prompt me the same error message, obviously in English. With an older version the installer of .NET 2.0 SP1, however, no problem, everything works perfectly. Well, this is my experience, not exaclty Vista related, but I hope that can help.
    Again, many thanks for the effort that you put in developing of this excellent program, and best wishes for Christmas and a happy new year.

  4. Kevin says:

    Hey, I just wanted to point out that I installed Paint.NET v3.36 on Windows 7 (beta build 7000) without a hitch.

Comments are closed.